<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8"/>
    <title>Swift Code Formatters - NSHipster</title>
    <meta name="description" content="Over the past few days, the Swift community has been buzzing about the latest pitch to adopt an an official style guide and formatting tool for the language. Let's take a look at where we're at today, how the proposed `swift-format` tool stacks up, and what we might expect in the future."/>
    <link rel="canonical" href="https://nshipster.com/swift-format/"/>
    <meta name="revisit-after" content="7 days"/>
    <meta name="viewport" content="width=device-width, initial-scale=1.0, viewport-fit=cover"/>
    <meta name="format-detection" content="telephone=no"/>
    <link rel="alternate" type="application/atom+xml" title="NSHipster Atom Feed" href="/feed.xml"/>
    <link rel="preload" as="font" href="/assets/nshipster-e474c0004ccdeca4e27e7ae1320e0e04a943b0ea5348b336356b7ac223497fda.woff2" type="font/woff2" crossorigin="anonymous" />
    <style rel="stylesheet" type="text/css" integrity="sha256-T39Y8e8bc2tQIlRsF2C4f4k0NKVV5CtwEU5fvGoZC7E=" crossorigin="anonymous">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</style>
    <link rel="apple-touch-icon" href="/apple-touch-icon.png"/>
    <link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"/>
    <link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"/>
    <link rel="manifest" href="/site.webmanifest"/>
    <link rel="mask-icon" href="/safari-pinned-tab.svg" color="#292724"/>
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-title" content="NSHipster"/>
    <meta name="application-name" content="NSHipster"/>
    <meta name="msapplication-TileColor" content="#f8f7f5"/>
    <meta name="theme-color" content="#f8f7f5"/>
    <link rel="author" type="text/plain" href="/humans.txt"/>
    <link rel="license" href="https://creativecommons.org/licenses/by-nc/4.0/"/>
    <meta name="twitter:card" content="summary"/>
    <meta name="twitter:site" content="@NSHipster"/>
    <meta name="twitter:title" content="Swift Code Formatters"/>
    <meta name="twitter:description" content="Over the past few days, the Swift community has been buzzing about the latest pitch to adopt an an official style guide and formatting tool for the language. Let’s take a look at where we’re at today, how the proposed swift-format tool stacks up, and what we might expect in the future.
"/>
    <meta property="twitter:account_id" content="629523445"/>
    <meta property="og:site_name" content="NSHipster"/>
    <meta property="og:image" content="https://nshipster.com/logo.png"/>
    <meta property="og:type" content="article"/>
    <meta property="og:title" content="Swift Code Formatters"/>
    <meta property="og:url" content="https://nshipster.com/swift-format/"/>
    <meta property="og:description" content="Over the past few days, the Swift community has been buzzing about the latest pitch to adopt an an official style guide and formatting tool for the language. Let’s take a look at where we’re at today, how the proposed swift-format tool stacks up, and what we might expect in the future.
"/>
    <meta property="article:published_time" content="2019-03-04T00:00:00-08:00"/>
    <meta property="article:modified_time" content="2019-03-05T13:18:01-08:00"/>
    <meta property="article:tag" content="Swift"/>
    <meta property="article:publisher" content="https://www.facebook.com/NSHipster">
    <link rel="prev" href="https://nshipster.com/javascriptcore/" />
  </head>
  <body>
    <div class="container">
      <header role="banner">
        <h1 id="logo">
          <a href="/" title="NSHipster">
            <?xml version="1.0"?>
              <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 474.4 266.34">
                <g id="ns">
                  <path d="M16.05 5.37h68.38l88.78 157.52h.72V5.37h62.64V261H168.2L79.42 101.67h-.72V261H16.05z"/>
                  <path d="M294.78 175.06c1.43 30.07 20 39.73 48.33 39.73 20 0 40.81-7.16 40.81-26.13 0-22.55-36.52-26.85-73.39-37.23-36.52-10.38-74.82-26.85-74.82-73.75C235.71 21.84 291.91 0 339.88 0c50.84 0 102 24.7 102.39 82.34h-66.59c1.08-23.27-20.76-30.79-41.17-30.79-14.32 0-32.21 5-32.21 21.84 0 19.69 36.87 23.27 74.1 33.65 36.87 10.38 74.1 27.56 74.1 73.74 0 64.8-55.13 85.56-111.33 85.56-58.71 0-110.62-25.77-111-91.28z"/>
                </g>
                <g id="mustache">
                  <path d="M168.07 104.61c-59.6 3-113.84 79.27-168.07 12.52 0 90 141.25 181.77 237.2 97.14 95.36 84 237.2-7.75 237.2-97.14-74.5 91.78-149-85.83-237.2 26.81-23.84-31.58-47.08-40.52-69.13-39.33z"/>
                </g>
              </svg>
            </a>
          </h1>
        </header>
        <main>
          <article role="article" itemscope itemtype="https://schema.org/Article">
            <header role="heading">
              <h1 class="title" itemprop="name">
                <a href="/swift-format/">Swift Code Formatters</a>
              </h1>
              <div class="byline">
                Written by
                <span class="authors">
                  <a class="author" href="/authors/mattt/">Mattt</a>
                </span>
                <time datetime="2019-03-04T00:00:00-08:00" itemprop="datePublished">March 4<sup>th</sup>, 2019</time>
                <time datetime="2019-03-04T00:00:00-08:00" itemprop="dateModified" hidden aria-hidden="true">March 4<sup>th</sup>, 2019</time>
              </div>
              <link itemprop="image" href="https://nshipster.com/logo.png"/>
              <meta itemprop="headline" content="Swift Code Formatters"/>
              <div itemprop="publisher" itemscope itemtype="http://schema.org/Organization" hidden aria-hidden="true">
                <meta itemprop="name" content="NSHipster"/>
                <meta itemprop="logo" content="https://nshipster.com/logo.png"/>
              </div>
            </header>
            <div class="content" itemprop="articleBody">
              <blockquote>
                <p>I just left a hipster coffee shop.
                  It was packed with iOS devs,
                  whispering amongst each other about how
                  they can’t wait for Apple to release
                  an official style guide and formatter for Swift.</p>
              </blockquote>
              <p>Over the past few days,
                the community has been buzzing about
                the latest pitch from
                <a href="https://github.com/allevato" rel="noopener noreferrer">Tony Allevato</a> and
                <a href="https://github.com/dabrahams" rel="noopener noreferrer">Dave Abrahams</a>
                to adopt an official style guide and formatting tool for the Swift language.</p>
              <p><a href="https://forums.swift.org/t/pitch-an-official-style-guide-and-formatter-for-swift/21025" rel="noopener noreferrer">Dozens of community members have already weighed in on the draft proposal</a>.
                As with all matters of style,
                opinions are strong, and everybody has one.
                Fortunately,
                the discourse from the community
                has been generally constructive and insightful,
                articulating a diversity of viewpoints, use cases, and concerns.</p>
              <p>At the time of writing,
                it appears that a plurality, if not an outright majority of respondents
                are +1 (or more)
                for some degree of official guidance on formatting conventions.
                And those in favor of a sanctioned style guide
                would also like for there to be a tool
                that automatically diagnoses and fixes violations of these guidelines.
                However, others have expressed concerns about
                the extent to which these guidelines are applicable and configurable.</p>
              <p>This week on NSHipster,
                we’ll take a look at the current field of
                Swift formatters available today —
                including the <code>swift-format</code> tool released as part of the proposal —
                and see how they all stack up.
                From there,
                we’ll take a step back and try to put everything in perspective.</p>
              <p>But first,
                let’s start with a question:</p>
              <hr>
              <h2>
                <a class="anchor" aria-hidden="true" id="what-is-code-formatting" href="#what-is-code-formatting"></a>What is Code Formatting?</h2>
              <p>For our purposes,
                we’ll define <dfn>code formatting</dfn>
                as any change made to code that makes it easier to understand
                without changing its behavior.
                Although this definition extends to differences in equivalent forms,
                (e.g. <code>[Int]</code> vs. <code>Array&lt;Int&gt;</code>),
                we’ll limit our discussion here to whitespace and punctuation.</p>
              <p>Swift, like many other programming languages,
                is quite liberal in its acceptance of newlines, tabs, and spaces.
                Most whitespace is insignificant,
                having no effect on the code around from the compiler’s point of view.</p>
              <p>When we use whitespace to make code more comprehensible
                without changing its behavior,
                that’s an example of
                <a href="https://en.wikipedia.org/wiki/Secondary_notation" rel="noopener noreferrer"><dfn>secondary notation</dfn></a>;
                the <dfn>primary notation</dfn>, of course,
                being the code itself.</p>
              <aside class="admonition info">
                <p>Another example of secondary notation is <dfn>syntax highlighting</dfn>,
                  discussed in <a href="/swiftsyntax/">a previous NSHipster article</a>.</p>
              </aside>
              <p>Put enough semicolons in the right places,
                and you can write pretty much anything in a single line of code.
                But all things being equal,
                why not use horizontal and vertical whitespace
                to visually structure code in a way that’s easier for us to understand,
                right?</p>
              <p>Unfortunately,
                the ambiguity created by the compiler’s accepting nature of whitespace
                can often cause confusion and disagreement among programmers:
                <em>“Should I add a newline before a curly bracket?
                  How do I break up statements that extend beyond the width of the editor?”</em></p>
              <p>Organizations often codify guidelines for how to deal with these issues,
                but they’re often under-specified, under-enforced, and out-of-date.
                The role of a <dfn>code formatter</dfn>
                is to automatically enforce a set of conventions
                so that programmers can set aside their differences
                and get to work solving actual problems.</p>
              <h2>
                <a class="anchor" aria-hidden="true" id="formatter-tool-comparison" href="#formatter-tool-comparison"></a>Formatter Tool Comparison</h2>
              <p>The Swift community has considered questions of style from the very beginning.
                Style guides have existed from the very first days of Swift,
                as have various open source tools to automate the process
                of formatting code to match them.</p>
              <p>In order to get a sense of the current state of Swift code formatters,
                we’ll take a look at the following four tools:</p>
              <table>
                <thead>
                  <tr>
                    <th>Project</th>
                    <th>Repository URL</th>
                  </tr>
                </thead>
                <tbody>
                  <tr>
                    <td><a href="#swiftformat" rel="noopener noreferrer">SwiftFormat</a></td>
                    <td><a href="https://github.com/nicklockwood/SwiftFormat" rel="noopener noreferrer">https://github.com/nicklockwood/SwiftFormat</a></td>
                  </tr>
                  <tr>
                    <td><a href="#swiftlint" rel="noopener noreferrer">SwiftLint</a></td>
                    <td><a href="https://github.com/realm/SwiftLint" rel="noopener noreferrer">https://github.com/realm/SwiftLint</a></td>
                  </tr>
                  <tr>
                    <td><a href="#prettier-with-swift-plugin" rel="noopener noreferrer">Prettier with Swift Plugin</a></td>
                    <td><a href="https://github.com/prettier/prettier" rel="noopener noreferrer">https://github.com/prettier/prettier</a></td>
                  </tr>
                  <tr>
                    <td><a href="#swift-format" rel="noopener noreferrer">swift-format (proposed)</a></td>
                    <td><a href="https://github.com/google/swift/tree/format" rel="noopener noreferrer">https://github.com/google/swift/tree/format</a></td>
                  </tr>
                </tbody>
              </table>
              <aside class="admonition info">
                <p>For brevity,
                  this article discusses only some of the Swift formatting tools available.
                  Here are some other ones that you may want to check out:
                  <a href="https://github.com/Jintin/Swimat" rel="noopener noreferrer">Swimat</a>,
                  <a href="https://github.com/inamiy/SwiftRewriter" rel="noopener noreferrer">SwiftRewriter</a>, and
                  <a href="https://github.com/kishikawakatsumi/swiftfmt" rel="noopener noreferrer">swiftfmt</a>.</p>
              </aside>
              <p>To establish a basis of comparison,
                we’ll use the following code sample to evaluate each tool
                (using their default configuration):</p>
              <pre class="highlight" data-lang="Swift"><code><span class="kd">struct</span> <span class="kt">Shipping<wbr></wbr>Address</span> <span class="p">:</span> <span class="kt">Codable</span>  <span class="p">{</span>
 <span class="k">var</span> <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span>
  <span class="k">var</span> <span class="nv">street<wbr></wbr>Address</span> <span class="p">:</span> <span class="kt">String</span>
   <span class="k">var</span> <span class="nv">locality</span> <span class="p">:</span><span class="kt">String</span>
    <span class="k">var</span> <span class="nv">region</span>   <span class="p">:</span><span class="kt">String</span><span class="p">;</span><span class="k">var</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span><span class="kt">String</span>
    <span class="k">var</span> <span class="nv">country</span><span class="p">:</span><span class="kt">String</span>

    <span class="nf">init</span><span class="p">(</span>     <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>        <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
<span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span><span class="nv">region</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span><span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span><span class="nv">country</span><span class="p">:</span><span class="kt">String</span>               <span class="p">)</span>
<span class="p">{</span>
    <span class="k">self</span><span class="o">.</span><span class="n">recipient</span> <span class="o">=</span> <span class="n">recipient</span>
    <span class="k">self</span><span class="o">.</span><span class="n">street<wbr></wbr>Address</span> <span class="o">=</span> <span class="n">street<wbr></wbr>Address</span>
        <span class="k">self</span><span class="o">.</span><span class="n">locality</span>  <span class="o">=</span> <span class="n">locality</span>
    <span class="k">self</span><span class="o">.</span><span class="n">region</span>        <span class="o">=</span> <span class="n">region</span><span class="p">;</span><span class="k">self</span><span class="o">.</span><span class="n">postal<wbr></wbr>Code</span><span class="o">=</span><span class="n">postal<wbr></wbr>Code</span>
        <span class="k">guard</span> <span class="n">country</span><span class="o">.</span><span class="n">count</span> <span class="o">==</span> <span class="mi">2</span><span class="p">,</span> <span class="n">country</span> <span class="o">==</span> <span class="n">country</span><span class="o">.</span><span class="nf">uppercased</span><span class="p">()</span> <span class="k">else</span> <span class="p">{</span> <span class="nf">fatal<wbr></wbr>Error</span><span class="p">(</span><span class="s">"invalid country code"</span><span class="p">)</span> <span class="p">}</span>
    <span class="k">self</span><span class="o">.</span><span class="n">country</span><span class="o">=</span><span class="n">country</span><span class="p">}}</span>

<span class="k">let</span> <span class="nv">apple<wbr></wbr>Park</span> <span class="o">=</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">(</span><span class="nv">recipient</span><span class="p">:</span><span class="s">"Apple, Inc."</span><span class="p">,</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span><span class="s">"1 Apple Park Way"</span><span class="p">,</span> <span class="nv">locality</span><span class="p">:</span><span class="s">"Cupertino"</span><span class="p">,</span> <span class="nv">region</span><span class="p">:</span><span class="s">"CA"</span><span class="p">,</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span><span class="s">"95014"</span><span class="p">,</span> <span class="nv">country</span><span class="p">:</span><span class="s">"US"</span><span class="p">)</span>
</code></pre>
              <p>Although code formatting encompasses a wide range of possible
                syntactic and semantic transformations,
                we’ll focus on newlines and indentation,
                which we believe to be baseline requirements for any code formatter.</p>
              <aside class="admonition info">
                <p>The performance benchmarks in this article are, admittedly, not very rigorous.
                  But they should provide some indication of general performance characteristics.
                  Timings are measured in seconds
                  and taken on a 2017 MacBook Pro
                  with 2.9 GHz Intel Core i7 processor and 16 GB 2133 MHz LPDDR3 memory.</p>
              </aside>
              <h3>
                <a class="anchor" aria-hidden="true" id="swiftformat" href="#swiftformat"></a>SwiftFormat</h3>
              <p>First up is
                <a href="https://github.com/nicklockwood/SwiftFormat" rel="noopener noreferrer">SwiftFormat</a>,
                a tool as helpful as it is self-descriptive.</p>
              <h4>
                <a class="anchor" aria-hidden="true" id="installation" href="#installation"></a>Installation</h4>
              <p>SwiftFormat is distributed via <a href="/homebrew/">Homebrew</a>
                as well as <a href="https://github.com/yonaskolb/Mint" rel="noopener noreferrer">Mint</a> and
                <a href="/CocoaPods/">CocoaPods</a>.</p>
              <p>You can install it by running the following command:</p>
              <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> brew <span class="nb">install </span>swiftformat
</code></pre>
              <p>In addition,
                SwiftFormat also provides an Xcode Source Editor Extension,
                found in the <a href="https://github.com/nicklockwood/SwiftFormat/tree/master/EditorExtension" rel="noopener noreferrer">EditorExtension</a>,
                which you can use to reformat code in Xcode.
                Or, if you’re a user of <a href="/vscode/">VSCode</a>,
                you can invoke SwiftFormat with
                <a href="https://marketplace.visualstudio.com/items?itemName=vknabel.vscode-swiftformat" rel="noopener noreferrer">this plugin</a>.</p>
              <h4>
                <a class="anchor" aria-hidden="true" id="usage" href="#usage"></a>Usage</h4>
              <p>The <code>swiftformat</code> command formats each Swift file
                found in the specified file and directory paths.</p>
              <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> swiftformat Example.swift
</code></pre>
              <p>SwiftFormat has a variety of rules that can be configured
                either individually via command-line options
                or using a configuration file.</p>
              <h4>
                <a class="anchor" aria-hidden="true" id="example" href="#example"></a>Example</h4>
              <p>Running the <code>swiftformat</code> command on our example
                using the default set of rules produces the following result:</p>
              <pre class="highlight" data-lang="Swift"><code><span class="c1">// swiftformat version 0.39.4</span>
<span class="kd">struct</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">Codable</span> <span class="p">{</span>
    <span class="k">var</span> <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">region</span><span class="p">:</span> <span class="kt">String</span><span class="p">;</span> <span class="k">var</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span>

    <span class="nf">init</span><span class="p">(</span><span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
         <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">region</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span><span class="p">)</span> <span class="p">{</span>
        <span class="k">self</span><span class="o">.</span><span class="n">recipient</span> <span class="o">=</span> <span class="n">recipient</span>
        <span class="k">self</span><span class="o">.</span><span class="n">street<wbr></wbr>Address</span> <span class="o">=</span> <span class="n">street<wbr></wbr>Address</span>
        <span class="k">self</span><span class="o">.</span><span class="n">locality</span> <span class="o">=</span> <span class="n">locality</span>
        <span class="k">self</span><span class="o">.</span><span class="n">region</span> <span class="o">=</span> <span class="n">region</span><span class="p">;</span> <span class="k">self</span><span class="o">.</span><span class="n">postal<wbr></wbr>Code</span> <span class="o">=</span> <span class="n">postal<wbr></wbr>Code</span>
        <span class="k">guard</span> <span class="n">country</span><span class="o">.</span><span class="n">count</span> <span class="o">==</span> <span class="mi">2</span><span class="p">,</span> <span class="n">country</span> <span class="o">==</span> <span class="n">country</span><span class="o">.</span><span class="nf">uppercased</span><span class="p">()</span> <span class="k">else</span> <span class="p">{</span> <span class="nf">fatal<wbr></wbr>Error</span><span class="p">(</span><span class="s">"invalid country code"</span><span class="p">)</span> <span class="p">}</span>
        <span class="k">self</span><span class="o">.</span><span class="n">country</span> <span class="o">=</span> <span class="n">country</span> <span class="p">}</span> <span class="p">}</span>

<span class="k">let</span> <span class="nv">apple<wbr></wbr>Park</span> <span class="o">=</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">(</span><span class="nv">recipient</span><span class="p">:</span> <span class="s">"Apple, Inc."</span><span class="p">,</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="s">"1 Apple Park Way"</span><span class="p">,</span> <span class="nv">locality</span><span class="p">:</span> <span class="s">"Cupertino"</span><span class="p">,</span> <span class="nv">region</span><span class="p">:</span> <span class="s">"CA"</span><span class="p">,</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="s">"95014"</span><span class="p">,</span> <span class="nv">country</span><span class="p">:</span> <span class="s">"US"</span><span class="p">)</span>
</code></pre>
              <p>As you can see,
                this is a clear improvement over the original.
                Each line is indented according to its scope,
                and each declaration has consistent spacing between punctuation.
                Both the semicolon in the property declarations
                and the newline in the initializer parameters are preserved;
                however, the closing curly braces aren’t moved to separate lines
                as might be expected.</p>
              <h4>
                <a class="anchor" aria-hidden="true" id="performance" href="#performance"></a>Performance</h4>
              <p>SwiftFormat is consistently the fastest of the tools tested in this article,
                completing in a few milliseconds.</p>
              <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> <span class="nb">time </span>swiftformat Example.swift
<span class="go">        0.03 real         0.01 user         0.01 sys
</span></code></pre>
              <h3>
                <a class="anchor" aria-hidden="true" id="swiftlint" href="#swiftlint"></a>SwiftLint</h3>
              <p>Next up is,
                <a href="https://github.com/realm/SwiftLint" rel="noopener noreferrer">SwiftLint</a>,
                a mainstay of the Swift open source community.
                With over 100 built-in rules,
                SwiftLint can perform a wide variety of checks on your code —
                everything from preferring <code>Any<wbr></wbr>Object</code> over <code>class</code> for class-only protocols
              to the so-called “Yoda condition rule”,
              which prescribes variables to be placed on
              the left-hand side of comparison operators
              (that is, <code>if n == 42</code> not <code>if 42 == n</code>).</p>
            <p>As its name implies,
              SwiftLint is not primarily a code formatter;
              it’s really a diagnostic tool for identifying
              convention violation and API misuse.
              However, by virtue of its auto-correction faculties,
              it’s frequently used to format code.</p>
            <h4>
              <a class="anchor" aria-hidden="true" id="installation-1" href="#installation-1"></a>Installation</h4>
            <p>You can install SwiftLint using Homebrew
              with the following command:</p>
            <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> brew <span class="nb">install </span>swiftlint
</code></pre>
            <p>Alternatively, you can install SwiftLint with
              <a href="/CocoaPods/">CocoaPods</a>,
              <a href="https://github.com/yonaskolb/Mint" rel="noopener noreferrer">Mint</a>,
              or as a <a href="https://github.com/realm/SwiftLint/releases/tag/0.31.0" rel="noopener noreferrer">standalone installer package (<code>.pkg</code>)</a>.</p>
            <h4>
              <a class="anchor" aria-hidden="true" id="usage-1" href="#usage-1"></a>Usage</h4>
            <p>To use SwiftLint as a code formatter,
              run the <code>autocorrect</code> subcommand
              passing the <code>--format</code> option
              and the files or directories to correct.</p>
            <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> swiftlint autocorrect <span class="nt">--format</span> <span class="nt">--path</span> Example.swift
</code></pre>
            <h4>
              <a class="anchor" aria-hidden="true" id="example-formatting" href="#example-formatting"></a>Example Formatting</h4>
            <p>Running the previous command on our example
              yields the following:</p>
            <pre class="highlight" data-lang="Swift"><code><span class="c1">// swiftlint version 0.31.0</span>
<span class="kd">struct</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">Codable</span> <span class="p">{</span>
    <span class="k">var</span> <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">region</span><span class="p">:</span> <span class="kt">String</span><span class="p">;</span><span class="k">var</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span>

    <span class="nf">init</span><span class="p">(</span>     <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
              <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">region</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span>               <span class="p">)</span> <span class="p">{</span>
        <span class="k">self</span><span class="o">.</span><span class="n">recipient</span> <span class="o">=</span> <span class="n">recipient</span>
        <span class="k">self</span><span class="o">.</span><span class="n">street<wbr></wbr>Address</span> <span class="o">=</span> <span class="n">street<wbr></wbr>Address</span>
        <span class="k">self</span><span class="o">.</span><span class="n">locality</span>  <span class="o">=</span> <span class="n">locality</span>
        <span class="k">self</span><span class="o">.</span><span class="n">region</span>        <span class="o">=</span> <span class="n">region</span><span class="p">;</span><span class="k">self</span><span class="o">.</span><span class="n">postal<wbr></wbr>Code</span><span class="o">=</span><span class="n">postal<wbr></wbr>Code</span>
        <span class="k">guard</span> <span class="n">country</span><span class="o">.</span><span class="n">count</span> <span class="o">==</span> <span class="mi">2</span><span class="p">,</span> <span class="n">country</span> <span class="o">==</span> <span class="n">country</span><span class="o">.</span><span class="nf">uppercased</span><span class="p">()</span> <span class="k">else</span> <span class="p">{</span> <span class="nf">fatal<wbr></wbr>Error</span><span class="p">(</span><span class="s">"invalid country code"</span><span class="p">)</span> <span class="p">}</span>
        <span class="k">self</span><span class="o">.</span><span class="n">country</span><span class="o">=</span><span class="n">country</span><span class="p">}}</span>

<span class="k">let</span> <span class="nv">apple<wbr></wbr>Park</span> <span class="o">=</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">(</span><span class="nv">recipient</span><span class="p">:</span> <span class="s">"Apple, Inc."</span><span class="p">,</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="s">"1 Apple Park Way"</span><span class="p">,</span> <span class="nv">locality</span><span class="p">:</span> <span class="s">"Cupertino"</span><span class="p">,</span> <span class="nv">region</span><span class="p">:</span> <span class="s">"CA"</span><span class="p">,</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="s">"95014"</span><span class="p">,</span> <span class="nv">country</span><span class="p">:</span> <span class="s">"US"</span><span class="p">)</span>
</code></pre>
            <p>SwiftLint cleans up the worst of the indentation and inter-spacing issues
              but leaves other, extraneous whitespace intact.
              Again, it’s worth noting that formatting isn’t SwiftLint’s primary calling;
              if anything, it’s merely incidental to providing actionable code diagnostics.
              And taken from the perspective of <em>“first, do no harm”</em>,
              it’s hard to complain about the results here.</p>
            <h4>
              <a class="anchor" aria-hidden="true" id="time" href="#time"></a>Time</h4>
            <p>For everything that SwiftLint checks for,
              it’s remarkably snappy —
              completing in a fraction of a second for our example.</p>
            <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> <span class="nb">time </span>swiftlint autocorrect <span class="nt">--quiet</span> <span class="nt">--format</span> <span class="nt">--path</span> Example.swift
<span class="go">        0.11 real         0.05 user         0.02 sys
</span></code></pre>
            <h3>
              <a class="anchor" aria-hidden="true" id="prettier-with-swift-plugin" href="#prettier-with-swift-plugin"></a>Prettier with Swift Plugin</h3>
            <p>If you’ve mostly shied away from JavaScript
              (as discussed in <a href="/javascriptcore/">last week’s article</a>),
              this may be the first you’ve heard of
              <a href="https://github.com/prettier/prettier" rel="noopener noreferrer">Prettier</a>.
              On the other hand,
              if you’re steeped in the world of ES6, React, and WebPack,
              you’ve almost certainly come to rely on it.</p>
            <p>Prettier is unique among code formatters in that it optimizes —
              first and foremost —
              for aesthetics,
              wrapping lines of code onto newlines as if they were poetry.</p>
            <p>Thanks to its (in-development) <a href="https://prettier.io/docs/en/plugins.html" rel="noopener noreferrer">plugin architecture</a>,
              the same line-breaking behavior can be applied to other languages,
              <a href="https://github.com/prettier/plugin-swift" rel="noopener noreferrer">including Swift</a>.</p>
            <aside class="admonition error">
              <p>The Prettier plugin for Swift is very much a work-in-progress
                and crashes when it encounters a syntax token it doesn’t have rules for
                (like <code>Enum<wbr></wbr>Decl</code> 😩).
              However, as you’ll see below,
              the results so far are too good to ignore,
              which is why we thought it worthwhile to include it in this round-up.</p>
          </aside>
          <h4>
            <a class="anchor" aria-hidden="true" id="installation-2" href="#installation-2"></a>Installation</h4>
          <p>To use Prettier and its plugin for Swift,
            you’ll have to wade into the murky waters of the Node packaging ecosystem.
            There are a few different approaches to get everything installed
            <em>(because of course there are)</em>,
            but <a href="https://yarnpkg.com/en/" rel="noopener noreferrer">Yarn</a> is our favorite 😻.</p>
          <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> brew <span class="nb">install </span>yarn
<span class="gp">$</span> yarn global add prettier prettier/plugin-swift
</code></pre>
          <h4>
            <a class="anchor" aria-hidden="true" id="usage-2" href="#usage-2"></a>Usage</h4>
          <p>With the <code>prettier</code> command-line tool accessible from our <code>$PATH</code>,
            run it with one or more file or directory paths.</p>
          <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> prettier Example.swift
</code></pre>
          <h4>
            <a class="anchor" aria-hidden="true" id="example-output" href="#example-output"></a>Example Output</h4>
          <p>Here’s the result of running the latest build of the Swift plugin with Prettier
            on our example from before:</p>
          <pre class="highlight" data-lang="Swift"><code><span class="c1">// prettier version 1.16.4</span>
<span class="c1">// prettier/plugin-swift version 0.0.0 (bdf8726)</span>
<span class="kd">struct</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">Codable</span> <span class="p">{</span>
    <span class="k">var</span> <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">region</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span>
    <span class="k">var</span> <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span>

    <span class="nf">init</span><span class="p">(</span>
        <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
        <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
        <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
        <span class="nv">region</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
        <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
        <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span>
    <span class="p">)</span> <span class="p">{</span>
        <span class="k">self</span><span class="o">.</span><span class="n">recipient</span> <span class="o">=</span> <span class="n">recipient</span>
        <span class="k">self</span><span class="o">.</span><span class="n">street<wbr></wbr>Address</span> <span class="o">=</span> <span class="n">street<wbr></wbr>Address</span>
        <span class="k">self</span><span class="o">.</span><span class="n">locality</span> <span class="o">=</span> <span class="n">locality</span>
        <span class="k">self</span><span class="o">.</span><span class="n">region</span> <span class="o">=</span> <span class="n">region</span><span class="p">;</span>
        <span class="k">self</span><span class="o">.</span><span class="n">postal<wbr></wbr>Code</span> <span class="o">=</span> <span class="n">postal<wbr></wbr>Code</span>
        <span class="k">guard</span> <span class="n">country</span><span class="o">.</span><span class="n">count</span> <span class="o">==</span> <span class="mi">2</span><span class="p">,</span> <span class="n">country</span> <span class="o">==</span> <span class="n">country</span><span class="o">.</span><span class="nf">uppercased</span><span class="p">()</span> <span class="k">else</span> <span class="p">{</span>
            <span class="nf">fatal<wbr></wbr>Error</span><span class="p">(</span><span class="s">"invalid country code"</span><span class="p">)</span>
        <span class="p">}</span>
        <span class="k">self</span><span class="o">.</span><span class="n">country</span> <span class="o">=</span> <span class="n">country</span>
    <span class="p">}</span>
<span class="p">}</span>

<span class="k">let</span> <span class="nv">apple<wbr></wbr>Park</span> <span class="o">=</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">(</span>
    <span class="nv">recipient</span><span class="p">:</span> <span class="s">"Apple, Inc."</span><span class="p">,</span>
    <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="s">"1 Apple Park Way"</span><span class="p">,</span>
    <span class="nv">locality</span><span class="p">:</span> <span class="s">"Cupertino"</span><span class="p">,</span>
    <span class="nv">region</span><span class="p">:</span> <span class="s">"CA"</span><span class="p">,</span>
    <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="s">"95014"</span><span class="p">,</span>
    <span class="nv">country</span><span class="p">:</span> <span class="s">"US"</span>
<span class="p">)</span>
</code></pre>
          <p>Prettier describes itself to be “An opinionated code formatter”.
            In practice, this means that there isn’t much in the way of configuration;
            there are only two options: “regular code” and “prettier code”.</p>
          <p>Now, you may object to the increase in vertical whitespace,
            but you’d be lying if you said this code didn’t look <em>amazing</em>.
            The way that everything is evenly spaced…
            the way that long lines are wrapped and indented…
            it’s almost hard to believe that you achieve something like this automatically.</p>
          <p>Of course, our caveat from before still applies:
            This is still very much a work-in-progress
            and isn’t suitable for production use yet.
            Also, there’s the matter of performance…</p>
          <h4>
            <a class="anchor" aria-hidden="true" id="timing" href="#timing"></a>Timing</h4>
          <p>To put it bluntly:
            Prettier is one or two orders of magnitude slower
            than every other tool discussed in this article.</p>
          <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> <span class="nb">time </span>prettier Example.swift
<span class="go">1.14 real         0.56 user         0.38 sys
</span></code></pre>
          <p>It’s unclear whether this is
            a consequence of navigating a language barrier or
            an opportunity for optimization,
            but Prettier is slow enough to cause problems at scale.</p>
          <p>For now,
            we recommend using Prettier only for one-off formatting tasks,
            such as writing code for articles and books.</p>
          <h3>
            <a class="anchor" aria-hidden="true" id="swift-format" href="#swift-format"></a>swift-format</h3>
          <p>Having looked at the current landscape of available Swift formatters,
            we now have a reasonable baseline for evaluating the <code>swift-format</code> tool
            proposed by Tony Allevato and Dave Abrahams.</p>
          <h4>
            <a class="anchor" aria-hidden="true" id="installation-3" href="#installation-3"></a>Installation</h4>
          <p>The code for <code>swift-format</code> is currently hosted on
            <a href="https://github.com/google/swift/tree/format" rel="noopener noreferrer">the <code>format</code> branch of Google’s fork of the Swift project</a>.
            You can check it out and build it from source by running the following commands:</p>
          <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> git clone https://github.com/google/swift.git swift-format
<span class="gp">$</span> <span class="nb">cd </span>swift-format
<span class="gp">$</span> git submodule update <span class="nt">--init</span>
<span class="gp">$</span> swift build
</code></pre>
          <p>For your convenience,
            we’re providing a Homebrew formula that builds from
            <a href="https://github.com/NSHipster/swift-format" rel="noopener noreferrer">our own fork of Google’s fork</a>,
            which you can install with the following command:</p>
          <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> brew <span class="nb">install </span>nshipster/formulae/swift-format
</code></pre>
          <h4>
            <a class="anchor" aria-hidden="true" id="usage-3" href="#usage-3"></a>Usage</h4>
          <p>Run the <code>swift-format</code> command,
            passing one or more file and directory paths
            to Swift files that you want to format.</p>
          <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> swift-format Example.swift
</code></pre>
          <p>The <code>swift-format</code> command also takes a <code>--configuration</code> option,
            which takes a path to a JSON file.
            For now,
            the easiest way to customize <code>swift-format</code> behavior
            is to dump the default configuration to a file
            and go from there.</p>
          <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> swift-format <span class="nt">-m</span> dump-configuration .swift-format.json
</code></pre>
          <p>Running the command above populates the specified file
            with the following JSON:</p>
          <pre class="highlight" data-lang="JSON"><code><span class="p">{</span><span class="w">
  </span><span class="s2">"blank<wbr></wbr>Line<wbr></wbr>Between<wbr></wbr>Members"</span><span class="p">:</span><span class="w"> </span><span class="p">{</span><span class="w">
    </span><span class="s2">"ignore<wbr></wbr>Single<wbr></wbr>Line<wbr></wbr>Properties"</span><span class="p">:</span><span class="w"> </span><span class="kc">true</span><span class="w">
  </span><span class="p">},</span><span class="w">
  </span><span class="s2">"indentation"</span><span class="p">:</span><span class="w"> </span><span class="p">{</span><span class="w">
    </span><span class="s2">"spaces"</span><span class="p">:</span><span class="w"> </span><span class="mi">2</span><span class="w">
  </span><span class="p">},</span><span class="w">
  </span><span class="s2">"line<wbr></wbr>Length"</span><span class="p">:</span><span class="w"> </span><span class="mi">100</span><span class="p">,</span><span class="w">
  </span><span class="s2">"maximum<wbr></wbr>Blank<wbr></wbr>Lines"</span><span class="p">:</span><span class="w"> </span><span class="mi">1</span><span class="p">,</span><span class="w">
  </span><span class="s2">"respects<wbr></wbr>Existing<wbr></wbr>Line<wbr></wbr>Breaks"</span><span class="p">:</span><span class="w"> </span><span class="kc">true</span><span class="p">,</span><span class="w">
  </span><span class="s2">"tab<wbr></wbr>Width"</span><span class="p">:</span><span class="w"> </span><span class="mi">8</span><span class="p">,</span><span class="w">
  </span><span class="s2">"version"</span><span class="p">:</span><span class="w"> </span><span class="mi">1</span><span class="w">
</span><span class="p">}</span><span class="w">
</span></code></pre>
          <p>After fiddling with the configuration —
            such as setting <code>line<wbr></wbr>Length</code> to the correct value of 80 <em>(don’t @ me)</em> —
          you can apply it thusly:</p>
        <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> swift-format Example.swift <span class="nt">--configuration</span> .swift-format.json
</code></pre>
        <h4>
          <a class="anchor" aria-hidden="true" id="example-output-1" href="#example-output-1"></a>Example Output</h4>
        <p>Using its default configuration,
          here’s how <code>swift-format</code> formats our example:</p>
        <pre class="highlight" data-lang="Swift"><code><span class="c1">// swift-format version 0.0.1</span>
<span class="kd">struct</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">Codable</span> <span class="p">{</span>
  <span class="k">var</span> <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span>
  <span class="k">var</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span>
  <span class="k">var</span> <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span>
  <span class="k">var</span> <span class="nv">region</span>   <span class="p">:</span><span class="kt">String</span><span class="p">;</span>
  <span class="k">var</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span>
  <span class="k">var</span> <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span>

  <span class="nf">init</span><span class="p">(</span>
    <span class="nv">recipient</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span>
    <span class="nv">locality</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">region</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="kt">String</span><span class="p">,</span> <span class="nv">country</span><span class="p">:</span> <span class="kt">String</span>
  <span class="p">)</span>
  <span class="p">{</span>
    <span class="k">self</span><span class="o">.</span><span class="n">recipient</span> <span class="o">=</span> <span class="n">recipient</span>
    <span class="k">self</span><span class="o">.</span><span class="n">street<wbr></wbr>Address</span> <span class="o">=</span> <span class="n">street<wbr></wbr>Address</span>
    <span class="k">self</span><span class="o">.</span><span class="n">locality</span> <span class="o">=</span> <span class="n">locality</span>
    <span class="k">self</span><span class="o">.</span><span class="n">region</span> <span class="o">=</span> <span class="n">region</span>
    <span class="k">self</span><span class="o">.</span><span class="n">postal<wbr></wbr>Code</span> <span class="o">=</span> <span class="n">postal<wbr></wbr>Code</span>
    <span class="k">guard</span> <span class="n">country</span><span class="o">.</span><span class="n">count</span> <span class="o">==</span> <span class="mi">2</span><span class="p">,</span> <span class="n">country</span> <span class="o">==</span> <span class="n">country</span><span class="o">.</span><span class="nf">uppercased</span><span class="p">()</span> <span class="k">else</span> <span class="p">{</span>
      <span class="nf">fatal<wbr></wbr>Error</span><span class="p">(</span><span class="s">"invalid country code"</span><span class="p">)</span>
    <span class="p">}</span>
    <span class="k">self</span><span class="o">.</span><span class="n">country</span> <span class="o">=</span> <span class="n">country</span>
  <span class="p">}</span>
<span class="p">}</span>

<span class="k">let</span> <span class="nv">apple<wbr></wbr>Park</span> <span class="o">=</span> <span class="kt">Shipping<wbr></wbr>Address</span><span class="p">(</span>
  <span class="nv">recipient</span><span class="p">:</span> <span class="s">"Apple, Inc."</span><span class="p">,</span> <span class="nv">street<wbr></wbr>Address</span><span class="p">:</span> <span class="s">"1 Apple Park Way"</span><span class="p">,</span> <span class="nv">locality</span><span class="p">:</span> <span class="s">"Cupertino"</span><span class="p">,</span> <span class="nv">region</span><span class="p">:</span> <span class="s">"CA"</span><span class="p">,</span>
  <span class="nv">postal<wbr></wbr>Code</span><span class="p">:</span> <span class="s">"95014"</span><span class="p">,</span> <span class="nv">country</span><span class="p">:</span> <span class="s">"US"</span><span class="p">)</span>
</code></pre>
        <p>For a version <code>0.0.1</code> release,
          this is promising!
          We could do without the original semicolon
          and don’t much care for the colon placement for the <code>region</code> property, either,
          but overall, this is pretty unobjectionable —
          which is exactly what you’d want from an official code style tool.</p>
        <h4>
          <a class="anchor" aria-hidden="true" id="timing-1" href="#timing-1"></a>Timing</h4>
        <p>In terms of performance,
          <code>swift-format</code> is currently in the middle of the pack:
          not so fast as to feel instantaneous,
          but not so slow as to be an issue.</p>
        <pre class="highlight" data-lang="Terminal"><code><span class="gp">$</span> <span class="nb">time </span>swift-format Example.swift
<span class="go">        0.51 real         0.20 user         0.27 sys
</span></code></pre>
        <hr>
        <p>Based on our initial investigation (albeit limited),
          <code>swift-format</code> appears to offer a reasonable set of formatting conventions.
          Going forward, it will be helpful to create more motivated examples
          to help inform our collective beliefs about the contours
          of such a tool.</p>
        <p>No matter what,
          it’ll be interesting to see how the proposal changes
          and the discussion evolves around these issues.</p>
      </div>
      <footer role="complementary">
        <section id="revisions">
          <small>NSMutableHipster</small>
          <p>
            Questions? Corrections? <a href="https://github.com/NSHipster/articles/issues">Issues</a> and <a href="https://github.com/NSHipster/articles/blob/master/2019-03-04-swift-format.md">pull requests</a> are always welcome.
          </p>
          <p class="status">
            <em>This article uses Swift version 5.0.</em>
            Find status information for all articles on the <a href="/status/">status page</a>.
          </p>
        </section>
        <section id="attribution">
          <div class="contributor" itemprop="author" itemscope itemtype="https://schema.org/Person">
            <small>Written by</small>
            <img class="avatar" alt="Mattt" itemprop="image" src="/assets/mattt-93904827ef54896bb67f3a0d4abf548b9ecc93a51536bbc3326f24630512727d.jpg" draggable="false"/>
            <div class="details">
              <span itemprop="name"><a href="/authors/mattt/">Mattt</a></span>
              <p><a href="https://github.com/mattt" rel="noopener noreferrer">Mattt</a> (<a href="https://twitter.com/mattt" rel="noopener noreferrer">@mattt</a>)
                is a writer and developer in Portland, Oregon.
                He is the founder of NSHipster and <a href="https://flight.school" rel="noopener noreferrer">Flight School</a>,
                and the creator of several open source libraries,
                including <a href="https://github.com/afnetworking/afnetworking" rel="noopener noreferrer">AFNetworking</a>
                and <a href="https://github.com/alamofire/alamofire" rel="noopener noreferrer">Alamofire</a>.</p>
              <a href="https://plus.google.com/106751358503565042647?rel=author" rel="author"></a>
            </div>
          </div>
        </section>
        <section>
          <div id="continue">
            <small>Next Article</small>
            <article>
              <h1 class="title">
                <a rel="next" href="/uicollectionview/" title="UICollectionView">UICollection​View</a>
              </h1>
              <p>UICollectionView single-handedly changes the way we will design and develop iOS apps from here on out. This is not to say that collection views are in any way unknown or obscure. But being an NSHipster isn’t just about knowing obscure gems in the rough. Sometimes, it’s about knowing about up-and-comers before they become popular and sell out.</p>
            </article>
          </div>
        </section>
      </footer>
    </article>
    <script type="application/ld+json">
      {
        "@context": "https://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [{
            "@type": "ListItem",
            "position": 1,
            "item": {
              "@id": "https://nshipster.com",
              "name": "Articles"
            }
          },
          {
            "@type": "ListItem",
            "position": 2,
            "item": {
              "@id": "https://nshipster.com/swift-format/",
              "name": "Swift Code Formatters"
            }
          }
        ]
      }
    </script>
  </main>
  <footer role="contentinfo">
    <section class="credits colophon">
      <p>
        <i aria-hidden="true" class="icon-cc" title="Creative Commons"></i>
        <i aria-hidden="true" class="icon-by" title="Attribution"></i>
        <i aria-hidden="true" class="icon-nc" title="Non-Commercial"></i>
        NSHipster.com is released under a <a href="https://creativecommons.org/licenses/by-nc/4.0/" rel="license">Creative Commons BY-NC License</a>.
      </p>
      <p>
        NSHipster is also available in
        <a href="https://nshipster.cn" hreflang="zh-Hans">Chinese (Simplified)</a>,
        <a href="https://nshipster.co.kr" hreflang="ko">Korean</a>,
        <a href="https://nshipster.fr" hreflang="fr">French</a>, and
        <a href="https://nshipster.es" hreflang="es">Spanish</a>
        .
      </p>
      <a href="https://plus.google.com/105091289906267717942" rel="publisher" hidden aria-hidden="true"></a>
    </section>
  </footer>
</div>
<script async="async" src="/assets/application-7c59b22d22e826c0d17fc358aa9a2008daa8b396741ab2ef1a854e4780b0c624.js" integrity="sha256-fFmyLSLoJsDRf8NYqpogCNqos5Z0GrLvGoVOR4CwxiQ=" crossorigin="anonymous"></script>
<script type="application/ld+json">
  {
    "@context": "https://schema.org",
    "@type": "Organization",
    "name": "NSHipster",
    "legalName": "NSHipster, LLC",
    "url": "https://nshipster.com",
    "logo": "https://nshipster.com/logo.png",
    "foundingDate": "2012",
    "founders": [{
      "@type": "Person",
      "name": "Mattt"
    }],
    "sameAs": [
      "https://twitter.com/nshipster",
      "https://github.com/nshipster",
      "https://plus.google.com/+NSHipster",
      "https://www.facebook.com/NSHipster"
    ]
  }
</script>
<script type="application/ld+json">
  {
    "@context": "https://schema.org",
    "@type": "WebSite",
    "url": "https://nshipster.com",
    "name": "NSHipster",
    "author": {
      "@type": "Person",
      "name": "Mattt"
    },
    "description": "NSHipster is a journal of the overlooked bits in Objective-C, Swift, and Cocoa. Updated weekly.
  ",
    "publisher": "Read Evaluate Press, LLC"
  }
</script>
<script type="application/cereal+json">
    {
        "endpoint": "https://analytics.nshipster.com/",
        "property": 1
    }
</script>
<script async defer src="https://analytics.nshipster.com/tracker.js"></script></body>
</html>